summaryrefslogtreecommitdiffstats
path: root/Tests/DocTest/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-09-16 18:28:51 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-15 14:47:38 (GMT)
commit277bd1db98194fe7b48627add4442e9b7a8207a7 (patch)
tree3a77d9cf12f239d93c0f0c8ffab82f2e79af1c8c /Tests/DocTest/CMakeLists.txt
parent678aaad1336b9581889d7d219a2778b0b070a560 (diff)
downloadCMake-277bd1db98194fe7b48627add4442e9b7a8207a7.zip
CMake-277bd1db98194fe7b48627add4442e9b7a8207a7.tar.gz
CMake-277bd1db98194fe7b48627add4442e9b7a8207a7.tar.bz2
Drop CMAKE_STRICT mode
With our modern development workflow it is less likely a property will be added to C++ code without documentation. This mode only existed to support the DocTest which had very limited coverage of the properties anyway.
Diffstat (limited to 'Tests/DocTest/CMakeLists.txt')
-rw-r--r--Tests/DocTest/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/Tests/DocTest/CMakeLists.txt b/Tests/DocTest/CMakeLists.txt
deleted file mode 100644
index 837328e..0000000
--- a/Tests/DocTest/CMakeLists.txt
+++ /dev/null
@@ -1,7 +0,0 @@
-cmake_minimum_required (VERSION 2.6)
-project (DocTest)
-
-add_executable (DocTest DocTest.cxx)
-
-set_property(GLOBAL PROPERTY REPORT_UNDEFINED_PROPERTIES
- "${CMAKE_CURRENT_BINARY_DIR}/UndefinedProperties.txt")