summaryrefslogtreecommitdiffstats
path: root/Tests/EmptyLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2010-09-30 15:01:35 (GMT)
committerBen Boeckel <ben.boeckel@kitware.com>2010-09-30 15:01:35 (GMT)
commit220c5dc45a61b37603e17c09d3ed9e030df55196 (patch)
tree22116062abd1b9e2a98bd715944d055b8a8fefd6 /Tests/EmptyLibrary/CMakeLists.txt
parent4e137de7b1e49db168228607864e80a6960ec52f (diff)
downloadCMake-220c5dc45a61b37603e17c09d3ed9e030df55196.zip
CMake-220c5dc45a61b37603e17c09d3ed9e030df55196.tar.gz
CMake-220c5dc45a61b37603e17c09d3ed9e030df55196.tar.bz2
Add test that CMake errors with empty libs
When the library language cannot be determined, make sure CMake errors, not segfaults (bug #11230)
Diffstat (limited to 'Tests/EmptyLibrary/CMakeLists.txt')
-rw-r--r--Tests/EmptyLibrary/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/EmptyLibrary/CMakeLists.txt b/Tests/EmptyLibrary/CMakeLists.txt
new file mode 100644
index 0000000..baddbbf
--- /dev/null
+++ b/Tests/EmptyLibrary/CMakeLists.txt
@@ -0,0 +1,4 @@
+cmake_minimum_required(VERSION 2.6)
+project(TestEmptyLibrary)
+
+add_subdirectory(subdir)