summaryrefslogtreecommitdiffstats
path: root/Tests/ExportImport/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-02-05 21:10:36 (GMT)
committerBrad King <brad.king@kitware.com>2013-02-07 16:09:56 (GMT)
commit56ca8d4e6365d67901e0cff7f2bd99f174537a97 (patch)
tree17473ad1dd7b67c915b53a17b0bca243b500cc45 /Tests/ExportImport/CMakeLists.txt
parentf36c665df80e8e3f4eca0fed28b5d1c3df739552 (diff)
downloadCMake-56ca8d4e6365d67901e0cff7f2bd99f174537a97.zip
CMake-56ca8d4e6365d67901e0cff7f2bd99f174537a97.tar.gz
CMake-56ca8d4e6365d67901e0cff7f2bd99f174537a97.tar.bz2
Tests: Add generator toolset support
Propagate CMAKE_GENERATOR_TOOLSET through the test hierarchy so that all tests can build with the selected generator toolset, if any.
Diffstat (limited to 'Tests/ExportImport/CMakeLists.txt')
-rw-r--r--Tests/ExportImport/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/ExportImport/CMakeLists.txt b/Tests/ExportImport/CMakeLists.txt
index cb2aebd..b8368fc 100644
--- a/Tests/ExportImport/CMakeLists.txt
+++ b/Tests/ExportImport/CMakeLists.txt
@@ -41,6 +41,7 @@ add_custom_command(
--build-project Export
--build-target install
--build-generator ${CMAKE_GENERATOR}
+ --build-generator-toolset "${CMAKE_GENERATOR_TOOLSET}"
--build-makeprogram ${CMAKE_MAKE_PROGRAM}
--build-options -C${ExportImport_BINARY_DIR}/InitialCache.cmake
VERBATIM
@@ -62,6 +63,7 @@ add_custom_command(
--build-noclean
--build-project Import
--build-generator ${CMAKE_GENERATOR}
+ --build-generator-toolset "${CMAKE_GENERATOR_TOOLSET}"
--build-makeprogram ${CMAKE_MAKE_PROGRAM}
--build-options -C${ExportImport_BINARY_DIR}/InitialCache.cmake
VERBATIM