summaryrefslogtreecommitdiffstats
path: root/Tests/ExportImport/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-01-30 22:26:09 (GMT)
committerBrad King <brad.king@kitware.com>2008-01-30 22:26:09 (GMT)
commit109b5fc7a22b1f2e1711a7fcafff08c11f1bdb49 (patch)
treeef9f65cd1985267449764979424bacf497667498 /Tests/ExportImport/CMakeLists.txt
parent7902bc06aae07a9d4cde81ab41c3c86694d80a9b (diff)
downloadCMake-109b5fc7a22b1f2e1711a7fcafff08c11f1bdb49.zip
CMake-109b5fc7a22b1f2e1711a7fcafff08c11f1bdb49.tar.gz
CMake-109b5fc7a22b1f2e1711a7fcafff08c11f1bdb49.tar.bz2
ENH: Updated ExportImport test to try LINK_INTERFACE_LIBRARIES.
Diffstat (limited to 'Tests/ExportImport/CMakeLists.txt')
-rw-r--r--Tests/ExportImport/CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/Tests/ExportImport/CMakeLists.txt b/Tests/ExportImport/CMakeLists.txt
index 3fb2dd3..3088228 100644
--- a/Tests/ExportImport/CMakeLists.txt
+++ b/Tests/ExportImport/CMakeLists.txt
@@ -11,15 +11,20 @@ set_property(
PROPERTY SYMBOLIC 1
)
-# Build and install the exporter.
if(CMAKE_CONFIGURATION_TYPES)
- set(Export_CONFIG_TYPE -C "${CMAKE_CFG_INTDIR}")
+ set(NESTED_CONFIG_TYPE -C "${CMAKE_CFG_INTDIR}")
else(CMAKE_CONFIGURATION_TYPES)
- set(Export_CONFIG_TYPE)
+ if(CMAKE_BUILD_TYPE)
+ set(NESTED_CONFIG_TYPE -C "${CMAKE_BUILD_TYPE}")
+ else(CMAKE_BUILD_TYPE)
+ set(NESTED_CONFIG_TYPE)
+ endif(CMAKE_BUILD_TYPE)
endif(CMAKE_CONFIGURATION_TYPES)
+
+# Build and install the exporter.
add_custom_command(
OUTPUT ${ExportImport_BINARY_DIR}/ExportProject
- COMMAND ${CMAKE_CTEST_COMMAND} ${Export_CONFIG_TYPE}
+ COMMAND ${CMAKE_CTEST_COMMAND} ${NESTED_CONFIG_TYPE}
--build-and-test
${ExportImport_SOURCE_DIR}/Export
${ExportImport_BINARY_DIR}/Export
@@ -45,14 +50,9 @@ set_property(
)
# Build and install the importer.
-if(CMAKE_CONFIGURATION_TYPES)
- set(Import_CONFIG_TYPE -C "${CMAKE_CFG_INTDIR}")
-else(CMAKE_CONFIGURATION_TYPES)
- set(Import_CONFIG_TYPE)
-endif(CMAKE_CONFIGURATION_TYPES)
add_custom_command(
OUTPUT ${ExportImport_BINARY_DIR}/ImportProject
- COMMAND ${CMAKE_CTEST_COMMAND} ${Import_CONFIG_TYPE}
+ COMMAND ${CMAKE_CTEST_COMMAND} ${NESTED_CONFIG_TYPE}
--build-and-test
${ExportImport_SOURCE_DIR}/Import
${ExportImport_BINARY_DIR}/Import