summaryrefslogtreecommitdiffstats
path: root/Tests/ExternalProject/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-04-09 17:56:08 (GMT)
committerBrad King <brad.king@kitware.com>2009-04-09 17:56:08 (GMT)
commit68248be52ec69f06e41c52dcf950caf7d6f2da08 (patch)
tree6ae3d3ffc890aeb8f33b40e21d7b907fad93286e /Tests/ExternalProject/CMakeLists.txt
parentdfd95e100dc5fcfd428cdc00f1d79d44c99449ac (diff)
downloadCMake-68248be52ec69f06e41c52dcf950caf7d6f2da08.zip
CMake-68248be52ec69f06e41c52dcf950caf7d6f2da08.tar.gz
CMake-68248be52ec69f06e41c52dcf950caf7d6f2da08.tar.bz2
ENH: Allow lists in AddExternalProject arguments
The add_external_project function separates its arguments with ';' separators, so previously no command line argument could contain one. When specifying CMAKE_ARGS, some -D argument values may need to contain a semicolon to form lists in the external project cache. This adds add_external_project argument LIST_SEPARATOR to specify a list separator string. The separator is replaced by ';' in arguments to any command created to drive the external project. For example: add_external_project(... LIST_SEPARATOR :: CMAKE_ARGS -DSOME_LIST:STRING=A::B::C ...) passes "-DSOME_LIST:STRING=A;B;C" to CMake for the external project.
Diffstat (limited to 'Tests/ExternalProject/CMakeLists.txt')
-rw-r--r--Tests/ExternalProject/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/ExternalProject/CMakeLists.txt b/Tests/ExternalProject/CMakeLists.txt
index 37374c1..63ab7ef 100644
--- a/Tests/ExternalProject/CMakeLists.txt
+++ b/Tests/ExternalProject/CMakeLists.txt
@@ -117,16 +117,20 @@ endif()
set(proj TutorialStep1-LocalTAR)
add_external_project(${proj}
TAR "${CMAKE_CURRENT_SOURCE_DIR}/Step1.tar"
+ LIST_SEPARATOR ::
PATCH_COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_SOURCE_DIR}/Step1Patch.cmake
CMAKE_GENERATOR "${CMAKE_GENERATOR}"
CMAKE_ARGS -DCMAKE_INSTALL_PREFIX:PATH=${prefix}
+ -DTEST_LIST:STRING=A::B::C
INSTALL_COMMAND ""
)
set(proj TutorialStep1-LocalNoDirTAR)
add_external_project(${proj}
TAR "${CMAKE_CURRENT_SOURCE_DIR}/Step1NoDir.tar"
+ LIST_SEPARATOR @@
CMAKE_ARGS -DCMAKE_INSTALL_PREFIX:PATH=${prefix} -G ${CMAKE_GENERATOR} ${source_dir}/${proj}
+ -DTEST_LIST:STRING=1@@2@@3
INSTALL_COMMAND ""
)
add_external_project_step(${proj} mypatch