summaryrefslogtreecommitdiffstats
path: root/Tests/ExternalProjectUpdate/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@crascit.com>2023-05-21 06:46:26 (GMT)
committerCraig Scott <craig.scott@crascit.com>2023-05-21 12:08:23 (GMT)
commit1d29cf37a19880e8579de6b43e0e291aaaa494f3 (patch)
treec83b97e8b65b03514d158c3e00380753d97d2191 /Tests/ExternalProjectUpdate/CMakeLists.txt
parentfaa14ecfae264a6db2d096142a1b8953d1c2bb75 (diff)
downloadCMake-1d29cf37a19880e8579de6b43e0e291aaaa494f3.zip
CMake-1d29cf37a19880e8579de6b43e0e291aaaa494f3.tar.gz
CMake-1d29cf37a19880e8579de6b43e0e291aaaa494f3.tar.bz2
Tests: Reduce warning noise in ExternalProjectUpdate test
Diffstat (limited to 'Tests/ExternalProjectUpdate/CMakeLists.txt')
-rw-r--r--Tests/ExternalProjectUpdate/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/ExternalProjectUpdate/CMakeLists.txt b/Tests/ExternalProjectUpdate/CMakeLists.txt
index 1b84ff3..e8c67b8 100644
--- a/Tests/ExternalProjectUpdate/CMakeLists.txt
+++ b/Tests/ExternalProjectUpdate/CMakeLists.txt
@@ -70,7 +70,9 @@ if(NOT TEST_GIT_TAG)
endif()
if(do_git_tests)
- set(local_git_repo "../../LocalRepositories/GIT")
+ cmake_path(SET local_git_repo NORMALIZE
+ "${CMAKE_CURRENT_BINARY_DIR}/LocalRepositories/GIT"
+ )
# Unzip/untar the git repository in our source folder so that other
# projects below may use it to test git args of ExternalProject_Add
@@ -79,6 +81,7 @@ if(do_git_tests)
ExternalProject_Add(${proj}
SOURCE_DIR ${CMAKE_CURRENT_BINARY_DIR}/LocalRepositories/GIT
URL ${CMAKE_CURRENT_SOURCE_DIR}/gitrepo.tgz
+ DOWNLOAD_EXTRACT_TIMESTAMP NO
BUILD_COMMAND ""
CONFIGURE_COMMAND "${GIT_EXECUTABLE}" --version
INSTALL_COMMAND ""