summaryrefslogtreecommitdiffstats
path: root/Tests/FindBLAS/Test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-07-12 15:08:35 (GMT)
committerBrad King <brad.king@kitware.com>2021-07-12 15:11:37 (GMT)
commit31ac4b916525126c5d7f3a944a749b8989a456c5 (patch)
tree600a369af23eab5cbcb8207378e0998356dffb88 /Tests/FindBLAS/Test/CMakeLists.txt
parent57dcde19da24d211bad945fbbe7851abbf9bdab3 (diff)
downloadCMake-31ac4b916525126c5d7f3a944a749b8989a456c5.zip
CMake-31ac4b916525126c5d7f3a944a749b8989a456c5.tar.gz
CMake-31ac4b916525126c5d7f3a944a749b8989a456c5.tar.bz2
ci: Verify that Intel MKL is found when it is the only BLAS/LAPACK
Issue: #22403
Diffstat (limited to 'Tests/FindBLAS/Test/CMakeLists.txt')
-rw-r--r--Tests/FindBLAS/Test/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/FindBLAS/Test/CMakeLists.txt b/Tests/FindBLAS/Test/CMakeLists.txt
index 98e12d5..7379749 100644
--- a/Tests/FindBLAS/Test/CMakeLists.txt
+++ b/Tests/FindBLAS/Test/CMakeLists.txt
@@ -12,7 +12,8 @@ add_executable(test_var main.c)
target_link_libraries(test_var PRIVATE ${BLAS_LIBRARIES})
add_test(NAME test_var COMMAND test_var)
-if(BLA_VENDOR STREQUAL "Intel10_64lp")
+if((BLA_VENDOR STREQUAL "Intel10_64lp") OR
+ (BLA_VENDOR STREQUAL "All" AND EXPECT_All STREQUAL "Intel10_64lp"))
if(NOT BLAS_LIBRARIES MATCHES "^(-Wl,--start-group;)?[^;]*mkl_intel_lp64")
message(FATAL_ERROR "BLAS_LIBRARIES does not start in mkl_intel_lp64:\n ${BLAS_LIBRARIES}")
endif()