summaryrefslogtreecommitdiffstats
path: root/Tests/FindBoost/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@codelibre.net>2015-12-01 22:05:35 (GMT)
committerBrad King <brad.king@kitware.com>2015-12-02 14:40:17 (GMT)
commit9fd987507622c585f4e0131678654e0643fd9a50 (patch)
tree7999c9a31cd17d7999815452871ebed5515e2eb0 /Tests/FindBoost/CMakeLists.txt
parent3f9b081f6ee85e0691c36496d989edbe8382589d (diff)
downloadCMake-9fd987507622c585f4e0131678654e0643fd9a50.zip
CMake-9fd987507622c585f4e0131678654e0643fd9a50.tar.gz
CMake-9fd987507622c585f4e0131678654e0643fd9a50.tar.bz2
Tests: Add FindBoost testcase for imported targets
Enable by setting CMake_TEST_FindBoost to TRUE.
Diffstat (limited to 'Tests/FindBoost/CMakeLists.txt')
-rw-r--r--Tests/FindBoost/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindBoost/CMakeLists.txt b/Tests/FindBoost/CMakeLists.txt
new file mode 100644
index 0000000..259ee26
--- /dev/null
+++ b/Tests/FindBoost/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_test(NAME FindBoost.Test COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindBoost/Test"
+ "${CMake_BINARY_DIR}/Tests/FindBoost/Test"
+ ${build_generator_args}
+ --build-project TestFindBoost
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )