summaryrefslogtreecommitdiffstats
path: root/Tests/FindBoost/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-04-16 17:34:33 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-04-16 17:34:41 (GMT)
commitfc4324a27cb534080fa981a77391e0224df2ef67 (patch)
tree19bb5d943664e185dee189d088b6de09ba3defd1 /Tests/FindBoost/CMakeLists.txt
parent5ec9d16b5a955de40d1ba904d08479ab204c0cb7 (diff)
parent0b54f72e940503adfbd978d7f1dedc3da4799f52 (diff)
downloadCMake-fc4324a27cb534080fa981a77391e0224df2ef67.zip
CMake-fc4324a27cb534080fa981a77391e0224df2ef67.tar.gz
CMake-fc4324a27cb534080fa981a77391e0224df2ef67.tar.bz2
Merge topic 'Boost-Gentoo'
0b54f72e94 FindBoost: Fix detection with version suffixes on Gentoo Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !3237
Diffstat (limited to 'Tests/FindBoost/CMakeLists.txt')
-rw-r--r--Tests/FindBoost/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/FindBoost/CMakeLists.txt b/Tests/FindBoost/CMakeLists.txt
index 17a8ec7..58d795b 100644
--- a/Tests/FindBoost/CMakeLists.txt
+++ b/Tests/FindBoost/CMakeLists.txt
@@ -33,3 +33,16 @@ add_test(NAME FindBoost.TestHeaders COMMAND
--build-options ${build_options}
--test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
)
+
+if (CMake_TEST_FindBoost_Python)
+ add_test(NAME FindBoost.TestPython COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindBoost/TestPython"
+ "${CMake_BINARY_DIR}/Tests/FindBoost/TestPython"
+ ${build_generator_args}
+ --build-project TestFindBoostPython
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )
+endif ()