summaryrefslogtreecommitdiffstats
path: root/Tests/FindBoost/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Leigh <r.leigh@dundee.ac.uk>2016-04-17 15:24:51 (GMT)
committerRoger Leigh <r.leigh@dundee.ac.uk>2016-04-19 21:07:45 (GMT)
commit2c1b720e643aafd725a8c0be11913834704d7269 (patch)
tree99f5db85aeb07ccab6b934aa54e56a2d224e11f0 /Tests/FindBoost/CMakeLists.txt
parent7d4c99a957b37e6905af3fe6ea96b7fdf2b8359c (diff)
downloadCMake-2c1b720e643aafd725a8c0be11913834704d7269.zip
CMake-2c1b720e643aafd725a8c0be11913834704d7269.tar.gz
CMake-2c1b720e643aafd725a8c0be11913834704d7269.tar.bz2
FindBoost: Define Boost::boost for all boost versions
Diffstat (limited to 'Tests/FindBoost/CMakeLists.txt')
-rw-r--r--Tests/FindBoost/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/FindBoost/CMakeLists.txt b/Tests/FindBoost/CMakeLists.txt
index 259ee26..0e9527d 100644
--- a/Tests/FindBoost/CMakeLists.txt
+++ b/Tests/FindBoost/CMakeLists.txt
@@ -8,3 +8,14 @@ add_test(NAME FindBoost.Test COMMAND
--build-options ${build_options}
--test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
)
+
+add_test(NAME FindBoost.TestHeaders COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindBoost/TestHeaders"
+ "${CMake_BINARY_DIR}/Tests/FindBoost/TestHeaders"
+ ${build_generator_args}
+ --build-project TestFindBoostHeaders
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )