summaryrefslogtreecommitdiffstats
path: root/Tests/FindDoxygen/CMakeLists.txt
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@crascit.com>2017-12-27 13:13:39 (GMT)
committerCraig Scott <craig.scott@crascit.com>2018-01-02 20:59:59 (GMT)
commit1e6d1dd358dc7aace3a1effa4f1646e1272be3dc (patch)
tree74933f72b5f914d98603b2b64464673d42766db6 /Tests/FindDoxygen/CMakeLists.txt
parent497f4bb941a84bacfca2392759de6cb8e23b0684 (diff)
downloadCMake-1e6d1dd358dc7aace3a1effa4f1646e1272be3dc.zip
CMake-1e6d1dd358dc7aace3a1effa4f1646e1272be3dc.tar.gz
CMake-1e6d1dd358dc7aace3a1effa4f1646e1272be3dc.tar.bz2
FindDoxygen: Add DOXYGEN_VERBATIM_VARS for quote prevention
Each CMake variable listed in DOXYGEN_VERBATIM_VARS will not have any automatic quoting applied to it when written to the Doxyfile.
Diffstat (limited to 'Tests/FindDoxygen/CMakeLists.txt')
-rw-r--r--Tests/FindDoxygen/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindDoxygen/CMakeLists.txt b/Tests/FindDoxygen/CMakeLists.txt
index daceaa3..69b9eed 100644
--- a/Tests/FindDoxygen/CMakeLists.txt
+++ b/Tests/FindDoxygen/CMakeLists.txt
@@ -8,6 +8,16 @@ add_test(NAME FindDoxygen.SimpleTest COMMAND
--build-options ${build_options}
)
+add_test(NAME FindDoxygen.QuotingTest COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindDoxygen/QuotingTest"
+ "${CMake_BINARY_DIR}/Tests/FindDoxygen/QuotingTest"
+ --build-target allDocTargets
+ ${build_generator_args}
+ --build-options ${build_options}
+)
+
if(CMake_TEST_FindDoxygen_Dot)
add_test(NAME FindDoxygen.DotComponentTest COMMAND
${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>