summaryrefslogtreecommitdiffstats
path: root/Tests/FindDoxygen/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Turbov <i.zaufi@gmail.com>2017-04-10 09:37:35 (GMT)
committerAlex Turbov <i.zaufi@gmail.com>2017-05-24 03:15:45 (GMT)
commit59ffabfeece31db8026aaa715f3ab0dbfbf8bb7e (patch)
tree65f775818d96d8b8742e120c26307d33642e1f47 /Tests/FindDoxygen/CMakeLists.txt
parentae5f98a5e36da8cf3c75625ffb9a1d34aa2407cb (diff)
downloadCMake-59ffabfeece31db8026aaa715f3ab0dbfbf8bb7e.zip
CMake-59ffabfeece31db8026aaa715f3ab0dbfbf8bb7e.tar.gz
CMake-59ffabfeece31db8026aaa715f3ab0dbfbf8bb7e.tar.bz2
Improve Doxygen support
Except Graphviz's `dot` Doxygen may use few other utilities like `mscgen` (Message Sequence Chart) and `dia` (Diagram Editor). Now this module allows to manage Doxygen settings from `CMakeLists.txt` and forget about `Doxyfile`s. Also it provides a helper function to add a target to generate documentation: `doxygen_add_docs`. Implement code review notes: - Introduce `COMPONENTS` to find: `dot`, `mscgen` and `dia`; - Deprecate variables `DOXYGEN_SKIP_DOT`, `DOXYGEN_EXECUTABLE`, `DOXYGEN_DOT_EXECUTABLE`, `DOXYGEN_DOT_FOUND` in favour of `doxygen_add_docs ` usage instead; - Properly handle paths to found tools in Windows; - Prevent adding a custom target if Doxygen was not really found; - Introduce exported (executable) targets for found components. Co-Author: Craig Scott <craig.scott@crascit.com>
Diffstat (limited to 'Tests/FindDoxygen/CMakeLists.txt')
-rw-r--r--Tests/FindDoxygen/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/Tests/FindDoxygen/CMakeLists.txt b/Tests/FindDoxygen/CMakeLists.txt
new file mode 100644
index 0000000..daceaa3
--- /dev/null
+++ b/Tests/FindDoxygen/CMakeLists.txt
@@ -0,0 +1,20 @@
+add_test(NAME FindDoxygen.SimpleTest COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindDoxygen/SimpleTest"
+ "${CMake_BINARY_DIR}/Tests/FindDoxygen/SimpleTest"
+ --build-target allDocTargets
+ ${build_generator_args}
+ --build-options ${build_options}
+)
+
+if(CMake_TEST_FindDoxygen_Dot)
+ add_test(NAME FindDoxygen.DotComponentTest COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindDoxygen/DotComponentTestTest"
+ "${CMake_BINARY_DIR}/Tests/FindDoxygen/DotComponentTestTest"
+ ${build_generator_args}
+ --build-options ${build_options}
+ )
+endif()