summaryrefslogtreecommitdiffstats
path: root/Tests/FindDoxygen/CMakeLists.txt
diff options
context:
space:
mode:
authorNikita Sirgienko <warquark@gmail.com>2019-04-16 11:37:45 (GMT)
committerCraig Scott <craig.scott@crascit.com>2019-09-05 23:12:09 (GMT)
commit611eb26b9db1b0ff1e83a6983b6cdf79f2dca0d5 (patch)
tree232bbbaac29255caa6369ce70ac14f3e64265084 /Tests/FindDoxygen/CMakeLists.txt
parent3ec986ce8e8df269eb6b6b9f37e12b02194168fd (diff)
downloadCMake-611eb26b9db1b0ff1e83a6983b6cdf79f2dca0d5.zip
CMake-611eb26b9db1b0ff1e83a6983b6cdf79f2dca0d5.tar.gz
CMake-611eb26b9db1b0ff1e83a6983b6cdf79f2dca0d5.tar.bz2
FindDoxygen: add USE_STAMP_FILE option
The new option enables the behavior of only building if sources change.
Diffstat (limited to 'Tests/FindDoxygen/CMakeLists.txt')
-rw-r--r--Tests/FindDoxygen/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindDoxygen/CMakeLists.txt b/Tests/FindDoxygen/CMakeLists.txt
index 7ce98d5..41e6255 100644
--- a/Tests/FindDoxygen/CMakeLists.txt
+++ b/Tests/FindDoxygen/CMakeLists.txt
@@ -28,6 +28,16 @@ add_test(NAME FindDoxygen.AllTarget COMMAND
--test-command ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
)
+add_test(NAME FindDoxygen.StampFile COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindDoxygen/StampFile"
+ "${CMake_BINARY_DIR}/Tests/FindDoxygen/StampFile"
+ --build-target allDocTargets
+ ${build_generator_args}
+ --build-options ${build_options}
+)
+
if(CMake_TEST_FindDoxygen_Dot)
add_test(NAME FindDoxygen.DotComponentTest COMMAND
${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>