summaryrefslogtreecommitdiffstats
path: root/Tests/FindGIF/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Heinzler <m.heinzler@heinzler.de>2018-11-20 20:03:19 (GMT)
committerMaximilian Heinzler <m.heinzler@heinzler.de>2018-11-20 20:07:03 (GMT)
commit6962a41e6b83e1ead36ab26b06ebe81aeee0087a (patch)
tree41b7ae116e6e9b9bf562660628ed7457ffd1ab92 /Tests/FindGIF/CMakeLists.txt
parent5bc64fe6c25f3c02dda7d22eb65c07bdf2e6eb46 (diff)
downloadCMake-6962a41e6b83e1ead36ab26b06ebe81aeee0087a.zip
CMake-6962a41e6b83e1ead36ab26b06ebe81aeee0087a.tar.gz
CMake-6962a41e6b83e1ead36ab26b06ebe81aeee0087a.tar.bz2
FindGIF: Add test
This tests whether GIFLIB can be found and the linker works. For newer versions (>=5) it also tests if the version was parsed correctly.
Diffstat (limited to 'Tests/FindGIF/CMakeLists.txt')
-rw-r--r--Tests/FindGIF/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindGIF/CMakeLists.txt b/Tests/FindGIF/CMakeLists.txt
new file mode 100644
index 0000000..bac64af
--- /dev/null
+++ b/Tests/FindGIF/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_test(NAME FindGIF.Test COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindGIF/Test"
+ "${CMake_BINARY_DIR}/Tests/FindGIF/Test"
+ ${build_generator_args}
+ --build-project TestFindGIF
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )