summaryrefslogtreecommitdiffstats
path: root/Tests/FindGSL/CMakeLists.txt
diff options
context:
space:
mode:
authorKelly Thompson <kgt@lanl.gov>2014-12-17 15:10:23 (GMT)
committerBrad King <brad.king@kitware.com>2014-12-17 15:59:48 (GMT)
commit1b28e3b28b86de40ceb6d402b6f41f30eb0c8b59 (patch)
treef2f4fdd4b9ce8347cf753828c5daa4855e5829a5 /Tests/FindGSL/CMakeLists.txt
parentddd193fcddbf7e81ffcd51a6e51227342a78cc4e (diff)
downloadCMake-1b28e3b28b86de40ceb6d402b6f41f30eb0c8b59.zip
CMake-1b28e3b28b86de40ceb6d402b6f41f30eb0c8b59.tar.gz
CMake-1b28e3b28b86de40ceb6d402b6f41f30eb0c8b59.tar.bz2
FindGSL: Add module to find the GNU Scientific Library
Diffstat (limited to 'Tests/FindGSL/CMakeLists.txt')
-rw-r--r--Tests/FindGSL/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Tests/FindGSL/CMakeLists.txt b/Tests/FindGSL/CMakeLists.txt
new file mode 100644
index 0000000..45a3471
--- /dev/null
+++ b/Tests/FindGSL/CMakeLists.txt
@@ -0,0 +1,9 @@
+add_test(NAME FindGSL.rng COMMAND ${CMAKE_CTEST_COMMAND}
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindGSL/rng"
+ "${CMake_BINARY_DIR}/Tests/FindGSL/rng"
+ ${build_generator_args}
+ --build-project FindGSL_rng
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V
+ )