summaryrefslogtreecommitdiffstats
path: root/Tests/FindICU/Test/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@codelibre.net>2016-07-10 17:34:39 (GMT)
committerBrad King <brad.king@kitware.com>2016-07-13 13:15:16 (GMT)
commit4a63be15dd9f8afedda7f3b01d5ab80591806664 (patch)
tree5a8c6c7caa48f996607891422ee1da02ee3e3336 /Tests/FindICU/Test/CMakeLists.txt
parent03a50961f338462acc65db876c59e0045f0754d9 (diff)
downloadCMake-4a63be15dd9f8afedda7f3b01d5ab80591806664.zip
CMake-4a63be15dd9f8afedda7f3b01d5ab80591806664.tar.gz
CMake-4a63be15dd9f8afedda7f3b01d5ab80591806664.tar.bz2
FindICU: New module
Diffstat (limited to 'Tests/FindICU/Test/CMakeLists.txt')
-rw-r--r--Tests/FindICU/Test/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/Tests/FindICU/Test/CMakeLists.txt b/Tests/FindICU/Test/CMakeLists.txt
new file mode 100644
index 0000000..1247ac7
--- /dev/null
+++ b/Tests/FindICU/Test/CMakeLists.txt
@@ -0,0 +1,14 @@
+cmake_minimum_required(VERSION 3.1)
+project(TestFindICU LANGUAGES CXX)
+include(CTest)
+
+find_package(ICU REQUIRED COMPONENTS i18n uc)
+
+add_executable(test_icu_tgt main.cpp)
+target_link_libraries(test_icu_tgt ICU::i18n ICU::uc)
+add_test(NAME test_icu_tgt COMMAND test_icu_tgt)
+
+add_executable(test_icu_var main.cpp)
+target_include_directories(test_icu_var PRIVATE ${ICU_INCLUDE_DIRS})
+target_link_libraries(test_icu_var PRIVATE ${ICU_LIBRARIES})
+add_test(NAME test_icu_var COMMAND test_icu_var)