summaryrefslogtreecommitdiffstats
path: root/Tests/FindJNI/CMakeLists.txt
diff options
context:
space:
mode:
authorSergiu Deitsch <sergiu.deitsch@gmail.com>2022-03-13 14:56:33 (GMT)
committerSergiu Deitsch <sergiu.deitsch@gmail.com>2022-04-04 17:46:32 (GMT)
commit171d45c039eac3427a7ff7c4bbccba9f1414c68d (patch)
tree0083934798f2b2f88e9f5b37f65f7098efd1f76a /Tests/FindJNI/CMakeLists.txt
parent35e92ec61913d5fb30cd7ca3df2e1ad8728e7e98 (diff)
downloadCMake-171d45c039eac3427a7ff7c4bbccba9f1414c68d.zip
CMake-171d45c039eac3427a7ff7c4bbccba9f1414c68d.tar.gz
CMake-171d45c039eac3427a7ff7c4bbccba9f1414c68d.tar.bz2
FindJNI: added components and imported targets
Diffstat (limited to 'Tests/FindJNI/CMakeLists.txt')
-rw-r--r--Tests/FindJNI/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/FindJNI/CMakeLists.txt b/Tests/FindJNI/CMakeLists.txt
new file mode 100644
index 0000000..0a0f756
--- /dev/null
+++ b/Tests/FindJNI/CMakeLists.txt
@@ -0,0 +1,12 @@
+foreach(test IN ITEMS Minimal JVM AWT)
+ add_test(NAME FindJNI.${test} COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindJNI/${test}"
+ "${CMake_BINARY_DIR}/Tests/FindJNI/${test}"
+ ${build_generator_args}
+ --build-project Test${test}
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )
+endforeach()