summaryrefslogtreecommitdiffstats
path: root/Tests/FindLibRHash/Test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-11-03 17:29:31 (GMT)
committerBrad King <brad.king@kitware.com>2016-11-10 13:29:38 (GMT)
commit71180fc8aa1db84260552f494578401e3ddb6a84 (patch)
tree1e9c65c7356d3344b5bcc7dc6fc4acfde4f5fc14 /Tests/FindLibRHash/Test/CMakeLists.txt
parent3216e94cef3cd4afa558d9adef29921a9330935d (diff)
downloadCMake-71180fc8aa1db84260552f494578401e3ddb6a84.zip
CMake-71180fc8aa1db84260552f494578401e3ddb6a84.tar.gz
CMake-71180fc8aa1db84260552f494578401e3ddb6a84.tar.bz2
FindLibRHash: Add module to find the librhash package
Add it to a private source directory that is not installed so that we can use it for building CMake itself. This will allow it to mature before being distributed publicly.
Diffstat (limited to 'Tests/FindLibRHash/Test/CMakeLists.txt')
-rw-r--r--Tests/FindLibRHash/Test/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/Tests/FindLibRHash/Test/CMakeLists.txt b/Tests/FindLibRHash/Test/CMakeLists.txt
new file mode 100644
index 0000000..37e062a
--- /dev/null
+++ b/Tests/FindLibRHash/Test/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.7)
+project(TestFindLibRHash C)
+include(CTest)
+
+# CMake does not actually provide FindLibRHash publicly.
+set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../../Source/Modules)
+
+find_package(LibRHash REQUIRED)
+
+add_executable(test_librhash_tgt main.c)
+target_link_libraries(test_librhash_tgt LibRHash::LibRHash)
+add_test(NAME test_librhash_tgt COMMAND test_librhash_tgt)
+
+add_executable(test_librhash_var main.c)
+target_include_directories(test_librhash_var PRIVATE ${LibRHash_INCLUDE_DIRS})
+target_link_libraries(test_librhash_var PRIVATE ${LibRHash_LIBRARIES})
+add_test(NAME test_librhash_var COMMAND test_librhash_var)