summaryrefslogtreecommitdiffstats
path: root/Tests/FindPNG/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Thursfield <sam.thursfield@codethink.co.uk>2016-01-19 17:43:05 (GMT)
committerBrad King <brad.king@kitware.com>2016-01-21 18:58:15 (GMT)
commit9b08c6233052fa1c3d393ee474c874f997491f7b (patch)
treebccb66d49c87c0f6533a2286ce235be0dcbcb5d2 /Tests/FindPNG/CMakeLists.txt
parentc13ed964012bcdf3765ada195db66930d6a0fcf9 (diff)
downloadCMake-9b08c6233052fa1c3d393ee474c874f997491f7b.zip
CMake-9b08c6233052fa1c3d393ee474c874f997491f7b.tar.gz
CMake-9b08c6233052fa1c3d393ee474c874f997491f7b.tar.bz2
FindPNG: Create an imported PNG::PNG target (#15911)
Imported targets are now the recommended way of dealing with external library dependencies. Add one for FindPNG and update documentation accordingly. Also add a test case activated by CMake_TEST_FindPNG.
Diffstat (limited to 'Tests/FindPNG/CMakeLists.txt')
-rw-r--r--Tests/FindPNG/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindPNG/CMakeLists.txt b/Tests/FindPNG/CMakeLists.txt
new file mode 100644
index 0000000..c665b67
--- /dev/null
+++ b/Tests/FindPNG/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_test(NAME FindPNG.Test COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindPNG/Test"
+ "${CMake_BINARY_DIR}/Tests/FindPNG/Test"
+ ${build_generator_args}
+ --build-project TestFindPNG
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )