summaryrefslogtreecommitdiffstats
path: root/Tests/FindPackageTest/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-09-01 18:05:42 (GMT)
committerBrad King <brad.king@kitware.com>2009-09-01 18:05:42 (GMT)
commit07f029d6ef9fd4a3cbbf781b14ef94fc11bb2e50 (patch)
tree72211f91a2dbed29242451ee8a4fd64b932e3d6b /Tests/FindPackageTest/CMakeLists.txt
parent16ce84b06712a8f859a352804013805f8f8435c4 (diff)
downloadCMake-07f029d6ef9fd4a3cbbf781b14ef94fc11bb2e50.zip
CMake-07f029d6ef9fd4a3cbbf781b14ef94fc11bb2e50.tar.gz
CMake-07f029d6ef9fd4a3cbbf781b14ef94fc11bb2e50.tar.bz2
Test the user package registry
We teach the FindPackageTest to build a sample project that stores its build tree in the user package registry using export(PACKAGE), and then find it with find_package.
Diffstat (limited to 'Tests/FindPackageTest/CMakeLists.txt')
-rw-r--r--Tests/FindPackageTest/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/FindPackageTest/CMakeLists.txt b/Tests/FindPackageTest/CMakeLists.txt
index f82f4a1..a62756e 100644
--- a/Tests/FindPackageTest/CMakeLists.txt
+++ b/Tests/FindPackageTest/CMakeLists.txt
@@ -180,3 +180,16 @@ ENDIF()
IF(NOT "1.2" VERSION_EQUAL "1.2.0.0")
MESSAGE(SEND_ERROR "1.2 VERSION_EQUAL 1.2.0.0 is not true!")
ENDIF()
+
+#-----------------------------------------------------------------------------
+# Test export(PACKAGE) with find_package.
+MESSAGE(STATUS "Preparing export(PACKAGE) test project")
+TRY_COMPILE(EXPORTER_COMPILED
+ ${FindPackageTest_BINARY_DIR}/Exporter
+ ${FindPackageTest_SOURCE_DIR}/Exporter
+ CMakeTestExportPackage dummy
+ OUTPUT_VARIABLE output)
+MESSAGE(STATUS "Searching for export(PACKAGE) test project")
+SET(CMakeTestExportPackage_DIR "" CACHE FILEPATH
+ "Wipe out find results for testing." FORCE)
+FIND_PACKAGE(CMakeTestExportPackage 1.${CMAKE_VERSION} EXACT REQUIRED)