summaryrefslogtreecommitdiffstats
path: root/Tests/FindPackageTest/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-01-21 13:48:33 (GMT)
committerBrad King <brad.king@kitware.com>2008-01-21 13:48:33 (GMT)
commitf41b1e8e9148c62e186e0729c5a5144c51e944e9 (patch)
tree4c0b4a7d6829a94e2248e6fe583279f906317c3f /Tests/FindPackageTest/CMakeLists.txt
parent9198a92af9e9f05a90d544c76ffeb65aa1a5281e (diff)
downloadCMake-f41b1e8e9148c62e186e0729c5a5144c51e944e9.zip
CMake-f41b1e8e9148c62e186e0729c5a5144c51e944e9.tar.gz
CMake-f41b1e8e9148c62e186e0729c5a5144c51e944e9.tar.bz2
ENH: Implement version support in the find_package command module mode. Version numbers provided to the command are converted to variable settings to tell the FindXXX.cmake module what version is requested. This addresses issue #1645.
Diffstat (limited to 'Tests/FindPackageTest/CMakeLists.txt')
-rw-r--r--Tests/FindPackageTest/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/FindPackageTest/CMakeLists.txt b/Tests/FindPackageTest/CMakeLists.txt
index 5d21fee..8b3225e 100644
--- a/Tests/FindPackageTest/CMakeLists.txt
+++ b/Tests/FindPackageTest/CMakeLists.txt
@@ -22,6 +22,13 @@ IF(NOT FOO_DIR)
CMAKE_PREFIX_PATH = ${CMAKE_PREFIX_PATH}")
ENDIF(NOT FOO_DIR)
+LIST(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR})
+FIND_PACKAGE(VersionTestA 1)
+FIND_PACKAGE(VersionTestB 1.2)
+FIND_PACKAGE(VersionTestC 1.2.3)
+
+#-----------------------------------------------------------------------------
+
#SET(CMAKE_FIND_DEBUG_MODE 1)
# For purposes of the test wipe out previous find results.