summaryrefslogtreecommitdiffstats
path: root/Tests/FindPackageTest/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Neundorf <neundorf@kde.org>2013-02-20 18:35:11 (GMT)
committerBrad King <brad.king@kitware.com>2013-02-22 13:31:00 (GMT)
commit7bb1abe56a05ccc50ff2c56e2df60f305af17ca4 (patch)
tree89ed15067444ce611b43d6a297586becaa9b7b78 /Tests/FindPackageTest/CMakeLists.txt
parentf7029572ca5948ff87ba0c6e8aaff35f6fdab4f1 (diff)
downloadCMake-7bb1abe56a05ccc50ff2c56e2df60f305af17ca4.zip
CMake-7bb1abe56a05ccc50ff2c56e2df60f305af17ca4.tar.gz
CMake-7bb1abe56a05ccc50ff2c56e2df60f305af17ca4.tar.bz2
FPHSA: Add FOUND_VAR option to specify _FOUND variable name
In the new mode FPHSA now accepts a FOUND_VAR option, which can be set either to ExactCase_FOUND or UPPERCASE_FOUND, no other values are accepted. Also add tests for that, including failure. Alex
Diffstat (limited to 'Tests/FindPackageTest/CMakeLists.txt')
-rw-r--r--Tests/FindPackageTest/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindPackageTest/CMakeLists.txt b/Tests/FindPackageTest/CMakeLists.txt
index bca149b..a77713f 100644
--- a/Tests/FindPackageTest/CMakeLists.txt
+++ b/Tests/FindPackageTest/CMakeLists.txt
@@ -43,6 +43,16 @@ if(NOT LOTSOFCOMPONENTS_FOUND)
message(SEND_ERROR "LotsOfComponents not found !")
endif()
+find_package(SomePackage)
+if(NOT SomePackage_FOUND)
+ message(SEND_ERROR "SomePackage with FOUND_VAR SomePackage_FOUND not found !")
+endif()
+
+find_package(UpperCasePackage)
+if(NOT UPPERCASEPACKAGE_FOUND)
+ message(SEND_ERROR "UpperCasePackage with FOUND_VAR UPPERCASEPACKAGE_FOUND not found !")
+endif()
+
#-----------------------------------------------------------------------------
# Test system package registry if possible.
set(CMakeTestSystemPackage "")