summaryrefslogtreecommitdiffstats
path: root/Tests/FindPackageTest/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2015-02-23 21:23:11 (GMT)
committerBrad King <brad.king@kitware.com>2015-04-17 14:46:24 (GMT)
commitd1a6d15bcd4df3d3e347411bd457be32275fb594 (patch)
tree0f76369cc1c8806360a8caa1a7561667ab48dcb7 /Tests/FindPackageTest/CMakeLists.txt
parentcdc53b62c20605467334ecb80c474533e04ff26c (diff)
downloadCMake-d1a6d15bcd4df3d3e347411bd457be32275fb594.zip
CMake-d1a6d15bcd4df3d3e347411bd457be32275fb594.tar.gz
CMake-d1a6d15bcd4df3d3e347411bd457be32275fb594.tar.bz2
FPHSA: Always populate the ExactCase_FOUND variable (#15412).
The UPPERCASE name was inconsistent with config-packages, the find_dependency macro, and even FPHSA itself, which expects components to be specified with names matching ExactCase. The FOUND_VAR was only permitted to have two possible values, and now both are set for compatibility. Document it as obsolete, and adjust the code for the same. Users of the variable should just remove it.
Diffstat (limited to 'Tests/FindPackageTest/CMakeLists.txt')
-rw-r--r--Tests/FindPackageTest/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/Tests/FindPackageTest/CMakeLists.txt b/Tests/FindPackageTest/CMakeLists.txt
index f311fb9..8fafa3b 100644
--- a/Tests/FindPackageTest/CMakeLists.txt
+++ b/Tests/FindPackageTest/CMakeLists.txt
@@ -45,12 +45,18 @@ endif()
find_package(SomePackage)
if(NOT SomePackage_FOUND)
- message(SEND_ERROR "SomePackage with FOUND_VAR SomePackage_FOUND not found !")
+ message(SEND_ERROR "SomePackage not found !")
+endif()
+if(NOT SOMEPACKAGE_FOUND)
+ message(SEND_ERROR "SomePackage compatibility name SOMEPACKAGE_FOUND not set!")
endif()
find_package(UpperCasePackage)
+if(NOT UpperCasePackage_FOUND)
+ message(SEND_ERROR "UpperCasePackage not found!")
+endif()
if(NOT UPPERCASEPACKAGE_FOUND)
- message(SEND_ERROR "UpperCasePackage with FOUND_VAR UPPERCASEPACKAGE_FOUND not found !")
+ message(SEND_ERROR "SomePackage compatibility name SOMEPACKAGE_FOUND not set!")
endif()
#-----------------------------------------------------------------------------