summaryrefslogtreecommitdiffstats
path: root/Tests/FindPatch/CMakeLists.txt
diff options
context:
space:
mode:
authorJean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>2017-09-01 14:49:46 (GMT)
committerBrad King <brad.king@kitware.com>2017-09-01 15:46:28 (GMT)
commit2645cb6208ff62cd64deb9862e3eb4d1a81264b3 (patch)
tree92d79081b1afa903228cf246922eaced015cdca8 /Tests/FindPatch/CMakeLists.txt
parent671cc7490ca1dd732cbb3671d4732eb1ee1e180e (diff)
downloadCMake-2645cb6208ff62cd64deb9862e3eb4d1a81264b3.zip
CMake-2645cb6208ff62cd64deb9862e3eb4d1a81264b3.tar.gz
CMake-2645cb6208ff62cd64deb9862e3eb4d1a81264b3.tar.bz2
FindPatch: Add module to find 'patch' command-line tool
Diffstat (limited to 'Tests/FindPatch/CMakeLists.txt')
-rw-r--r--Tests/FindPatch/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/FindPatch/CMakeLists.txt b/Tests/FindPatch/CMakeLists.txt
new file mode 100644
index 0000000..541f5bd
--- /dev/null
+++ b/Tests/FindPatch/CMakeLists.txt
@@ -0,0 +1,8 @@
+add_test(NAME FindPatch.Test COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindPatch/Test"
+ "${CMake_BINARY_DIR}/Tests/FindPatch/Test"
+ ${build_generator_args}
+ --build-options ${build_options}
+)