summaryrefslogtreecommitdiffstats
path: root/Tests/FindProtobuf/CMakeLists.txt
diff options
context:
space:
mode:
authorFrank Lange <langefrq@gmx.de>2021-04-30 20:56:39 (GMT)
committerBrad King <brad.king@kitware.com>2021-05-06 17:42:21 (GMT)
commitf2a4b879b1cddce84c56de63809e831aea53d1ba (patch)
tree6ecff61d0f3059b2a27be53dc619d3bfe727f5b3 /Tests/FindProtobuf/CMakeLists.txt
parent5cbbe3d301838b361f7ff9ae7e09dc10ce089957 (diff)
downloadCMake-f2a4b879b1cddce84c56de63809e831aea53d1ba.zip
CMake-f2a4b879b1cddce84c56de63809e831aea53d1ba.tar.gz
CMake-f2a4b879b1cddce84c56de63809e831aea53d1ba.tar.bz2
FindProtobuf: Add PLUGIN parameter to protobuf_generate
This allows for example reusing the function for generating gRPC code by specifying which grpc plugin to use.
Diffstat (limited to 'Tests/FindProtobuf/CMakeLists.txt')
-rw-r--r--Tests/FindProtobuf/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/FindProtobuf/CMakeLists.txt b/Tests/FindProtobuf/CMakeLists.txt
index 1cdb2ae..b4ca29b 100644
--- a/Tests/FindProtobuf/CMakeLists.txt
+++ b/Tests/FindProtobuf/CMakeLists.txt
@@ -6,5 +6,6 @@ add_test(NAME FindProtobuf.Test COMMAND
${build_generator_args}
--build-project TestFindProtobuf
--build-options ${build_options}
+ "-DCMake_TEST_FindProtobuf_gRPC=${CMake_TEST_FindProtobuf_gRPC}"
--test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
)