summaryrefslogtreecommitdiffstats
path: root/Tests/FindPython/Python/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2020-10-01 15:47:37 (GMT)
committerMarc Chevrier <marc.chevrier@gmail.com>2020-10-01 15:51:16 (GMT)
commit5537ccd814700edb529e5e79137601bb2987c892 (patch)
treef5f8b3600b641516f0b4d4263b1f5455727e0e62 /Tests/FindPython/Python/CMakeLists.txt
parent0519db374c79f654b55de396943cafcf36db695f (diff)
downloadCMake-5537ccd814700edb529e5e79137601bb2987c892.zip
CMake-5537ccd814700edb529e5e79137601bb2987c892.tar.gz
CMake-5537ccd814700edb529e5e79137601bb2987c892.tar.bz2
FindPython: Tests optimizations
* Use 'project(... LANGUAGES NONE)' when possible * enhance error messages wording
Diffstat (limited to 'Tests/FindPython/Python/CMakeLists.txt')
-rw-r--r--Tests/FindPython/Python/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/Tests/FindPython/Python/CMakeLists.txt b/Tests/FindPython/Python/CMakeLists.txt
index e8828a2..9bec22f 100644
--- a/Tests/FindPython/Python/CMakeLists.txt
+++ b/Tests/FindPython/Python/CMakeLists.txt
@@ -1,18 +1,18 @@
cmake_minimum_required(VERSION 3.1)
-project(TestPython C)
+project(TestPython LANGUAGES C)
include(CTest)
find_package(Python ${Python_REQUESTED_VERSION} REQUIRED COMPONENTS Interpreter Development)
if (NOT Python_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION}")
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION}")
endif()
if (NOT Python_Development.Module_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION}, COMPONENT 'Development.Module'")
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION}, COMPONENT 'Development.Module'")
endif()
if (NOT Python_Development.Embed_FOUND)
- message (FATAL_ERROR "Fail to found Python ${Python_REQUESTED_VERSION}, COMPOENENT 'Development.Embed'")
+ message (FATAL_ERROR "Failed to find Python ${Python_REQUESTED_VERSION}, COMPOENENT 'Development.Embed'")
endif()
if(NOT TARGET Python::Interpreter)