summaryrefslogtreecommitdiffstats
path: root/Tests/FindPython/Python3/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Chevrier <marc.chevrier@gmail.com>2020-10-01 15:47:37 (GMT)
committerMarc Chevrier <marc.chevrier@gmail.com>2020-10-01 15:51:16 (GMT)
commit5537ccd814700edb529e5e79137601bb2987c892 (patch)
treef5f8b3600b641516f0b4d4263b1f5455727e0e62 /Tests/FindPython/Python3/CMakeLists.txt
parent0519db374c79f654b55de396943cafcf36db695f (diff)
downloadCMake-5537ccd814700edb529e5e79137601bb2987c892.zip
CMake-5537ccd814700edb529e5e79137601bb2987c892.tar.gz
CMake-5537ccd814700edb529e5e79137601bb2987c892.tar.bz2
FindPython: Tests optimizations
* Use 'project(... LANGUAGES NONE)' when possible * enhance error messages wording
Diffstat (limited to 'Tests/FindPython/Python3/CMakeLists.txt')
-rw-r--r--Tests/FindPython/Python3/CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/Tests/FindPython/Python3/CMakeLists.txt b/Tests/FindPython/Python3/CMakeLists.txt
index d6e5fdb..e40557d 100644
--- a/Tests/FindPython/Python3/CMakeLists.txt
+++ b/Tests/FindPython/Python3/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.1)
-project(TestPython3 C)
+project(TestPython3 LANGUAGES C)
include(CTest)
@@ -11,16 +11,16 @@ endif()
find_package(Python3 REQUIRED COMPONENTS Interpreter Development)
if (NOT Python3_FOUND)
- message (FATAL_ERROR "Fail to found Python 3")
+ message (FATAL_ERROR "Failed to find Python 3")
endif()
if (NOT Python3_Development_FOUND)
- message (FATAL_ERROR "Fail to found Python 3 'Development' component")
+ message (FATAL_ERROR "Failed to find Python 3 'Development' component")
endif()
if (NOT Python3_Development.Module_FOUND)
- message (FATAL_ERROR "Fail to found Python 3 'Development.Module' component")
+ message (FATAL_ERROR "Failed to find Python 3 'Development.Module' component")
endif()
if (NOT Python3_Development.Embed_FOUND)
- message (FATAL_ERROR "Fail to found Python 3 'Development.Embed' component")
+ message (FATAL_ERROR "Failed to find Python 3 'Development.Embed' component")
endif()
if(NOT TARGET Python3::Interpreter)