summaryrefslogtreecommitdiffstats
path: root/Tests/FindRuby/CMakeLists.txt
diff options
context:
space:
mode:
authorJulien Marrec <julien.marrec@gmail.com>2020-03-23 12:16:39 (GMT)
committerJulien Marrec <julien.marrec@gmail.com>2020-03-23 12:22:23 (GMT)
commit905d5667e8b49a931078a1bcea26deffe703453b (patch)
treec42c663aaca77453350c5aac602ef0a4d3407995 /Tests/FindRuby/CMakeLists.txt
parente6699b9b59a12f6fda8f535d370453bb41f3acce (diff)
downloadCMake-905d5667e8b49a931078a1bcea26deffe703453b.zip
CMake-905d5667e8b49a931078a1bcea26deffe703453b.tar.gz
CMake-905d5667e8b49a931078a1bcea26deffe703453b.tar.bz2
FindRuby: Add support for RVM installations
Diffstat (limited to 'Tests/FindRuby/CMakeLists.txt')
-rw-r--r--Tests/FindRuby/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/Tests/FindRuby/CMakeLists.txt b/Tests/FindRuby/CMakeLists.txt
index aaab839..3f4807c 100644
--- a/Tests/FindRuby/CMakeLists.txt
+++ b/Tests/FindRuby/CMakeLists.txt
@@ -41,4 +41,17 @@ if(CMake_TEST_FindRuby)
set_tests_properties(FindRuby.FailExact PROPERTIES
PASS_REGULAR_EXPRESSION "Could NOT find Ruby: Found unsuitable version \".*\", but required is.*exact version \"[0-9]+\\.[0-9]+\\.[0-9]+\" \\(found .*\\)")
+ # RVM specific test
+ if(CMake_TEST_FindRuby_RVM)
+ add_test(NAME FindRuby.Rvm COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindRuby/Rvm"
+ "${CMake_BINARY_DIR}/Tests/FindRuby/Rvm"
+ ${build_generator_args}
+ --build-project TestRVM
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )
+ endif()
endif()