summaryrefslogtreecommitdiffstats
path: root/Tests/FindTIFF/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@codelibre.net>2015-12-02 17:20:24 (GMT)
committerBrad King <brad.king@kitware.com>2015-12-07 14:20:08 (GMT)
commitebaca6290d2c0be7dec22452389632949a700d28 (patch)
tree52e2bc935c10f90e5eb61c12031335502e5ca9b0 /Tests/FindTIFF/CMakeLists.txt
parent4ffeab0e3c451854a4a9d424b47b2179c6cf6c6b (diff)
downloadCMake-ebaca6290d2c0be7dec22452389632949a700d28.zip
CMake-ebaca6290d2c0be7dec22452389632949a700d28.tar.gz
CMake-ebaca6290d2c0be7dec22452389632949a700d28.tar.bz2
FindTIFF: Add imported targets and update documentation
- Add TIFF::TIFF imported target - Document imported target - Add testcase to test the standard variables and the imported target Also: - Add TIFF_INCLUDE_DIRS to match common practice - Update documentation generally, including documenting TIFF_INCLUDE_DIRS
Diffstat (limited to 'Tests/FindTIFF/CMakeLists.txt')
-rw-r--r--Tests/FindTIFF/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindTIFF/CMakeLists.txt b/Tests/FindTIFF/CMakeLists.txt
new file mode 100644
index 0000000..c4e0c6a
--- /dev/null
+++ b/Tests/FindTIFF/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_test(NAME FindTIFF.Test COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindTIFF/Test"
+ "${CMake_BINARY_DIR}/Tests/FindTIFF/Test"
+ ${build_generator_args}
+ --build-project TestFindTIFF
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )