summaryrefslogtreecommitdiffstats
path: root/Tests/FindX11/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-11-19 14:57:17 (GMT)
committerKitware Robot <kwrobot@kitware.com>2018-11-19 14:57:46 (GMT)
commitb7b2ce56a7f215574144da390b803611b9e5eca1 (patch)
treee15a875341b5a02fa9e0a9a0aaeb9dca02a70aec /Tests/FindX11/CMakeLists.txt
parentd9d8816f39d625f7f5e6f87ec831badcff4f3f5d (diff)
parentbced9d5e568604509db43b16d8baa7f1c7b4e714 (diff)
downloadCMake-b7b2ce56a7f215574144da390b803611b9e5eca1.zip
CMake-b7b2ce56a7f215574144da390b803611b9e5eca1.tar.gz
CMake-b7b2ce56a7f215574144da390b803611b9e5eca1.tar.bz2
Merge topic 'findx11-imported-targets'
bced9d5e56 Tests/FindX11: add a test a7d2ffb232 FindX11: add imported targets 40b3dba529 FindX11: require Freetype and Fontconfig for Xft cc96249e2e FindX11: remove local variable from the advanced list 99489d9f10 FindX11: find Xext.h b8b598061a FindX11: match variables with library names 6079a0d00f FindX11: fix some formatting in the documentation 3c54955d0d FindX11: use `list(APPEND)` for clearer code ... Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !2604
Diffstat (limited to 'Tests/FindX11/CMakeLists.txt')
-rw-r--r--Tests/FindX11/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/FindX11/CMakeLists.txt b/Tests/FindX11/CMakeLists.txt
new file mode 100644
index 0000000..cc931a1
--- /dev/null
+++ b/Tests/FindX11/CMakeLists.txt
@@ -0,0 +1,10 @@
+add_test(NAME FindX11.Test COMMAND
+ ${CMAKE_CTEST_COMMAND} -C $<CONFIGURATION>
+ --build-and-test
+ "${CMake_SOURCE_DIR}/Tests/FindX11/Test"
+ "${CMake_BINARY_DIR}/Tests/FindX11/Test"
+ ${build_generator_args}
+ --build-project TestFindX11
+ --build-options ${build_options}
+ --test-command ${CMAKE_CTEST_COMMAND} -V -C $<CONFIGURATION>
+ )