summaryrefslogtreecommitdiffstats
path: root/Tests/FindXalanC/Test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-01-21 18:55:50 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2016-01-21 18:55:50 (GMT)
commitaaf06f2b0f4ce4085e2bf1c60ffc63065968a9c6 (patch)
tree1c41392253a1e8dd788552d3e8639686780663b2 /Tests/FindXalanC/Test/CMakeLists.txt
parent563a6c7be09c73bdd7e0ee7b0c52dd9bbc20c50a (diff)
parentf9e45ab9d412b08ded8a11ff1f4f0ef90e10358c (diff)
downloadCMake-aaf06f2b0f4ce4085e2bf1c60ffc63065968a9c6.zip
CMake-aaf06f2b0f4ce4085e2bf1c60ffc63065968a9c6.tar.gz
CMake-aaf06f2b0f4ce4085e2bf1c60ffc63065968a9c6.tar.bz2
Merge topic 'add-FindXalanC'
f9e45ab9 FindXalanC: New module to find the Apache Xalan-C++ library
Diffstat (limited to 'Tests/FindXalanC/Test/CMakeLists.txt')
-rw-r--r--Tests/FindXalanC/Test/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/Tests/FindXalanC/Test/CMakeLists.txt b/Tests/FindXalanC/Test/CMakeLists.txt
new file mode 100644
index 0000000..b445e0e
--- /dev/null
+++ b/Tests/FindXalanC/Test/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.1)
+project(TestFindXalanC CXX)
+include(CTest)
+
+# CMake does not actually provide FindXalanC publicly.
+set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../../Source/Modules)
+
+find_package(XalanC REQUIRED)
+
+add_executable(test_xalanc_tgt main.cxx)
+target_link_libraries(test_xalanc_tgt XalanC::XalanC)
+add_test(NAME test_xalanc_tgt COMMAND test_xalanc_tgt)
+
+add_executable(test_xalanc_var main.cxx)
+target_include_directories(test_xalanc_var PRIVATE ${XalanC_INCLUDE_DIRS})
+target_link_libraries(test_xalanc_var PRIVATE ${XalanC_LIBRARIES})
+add_test(NAME test_xalanc_var COMMAND test_xalanc_var)