summaryrefslogtreecommitdiffstats
path: root/Tests/Fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-09-05 19:40:01 (GMT)
committerBrad King <brad.king@kitware.com>2014-09-10 15:21:50 (GMT)
commit09ab207c668deadea3635a20812fa2f478c17f9f (patch)
tree7c3bdee26a650942d2659573d523752daa1e964a /Tests/Fortran/CMakeLists.txt
parent6944997bd6aa69fdf88f8e4e154e68d57195b20b (diff)
downloadCMake-09ab207c668deadea3635a20812fa2f478c17f9f.zip
CMake-09ab207c668deadea3635a20812fa2f478c17f9f.tar.gz
CMake-09ab207c668deadea3635a20812fa2f478c17f9f.tar.bz2
Tests: Add generator platform support
Propagate CMAKE_GENERATOR_PLATFORM through the test hierarchy so that all tests can build with the selected generator platform, if any.
Diffstat (limited to 'Tests/Fortran/CMakeLists.txt')
-rw-r--r--Tests/Fortran/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/Fortran/CMakeLists.txt b/Tests/Fortran/CMakeLists.txt
index ef3b317..1982a60 100644
--- a/Tests/Fortran/CMakeLists.txt
+++ b/Tests/Fortran/CMakeLists.txt
@@ -201,6 +201,7 @@ if(TEST_MODULE_DEPENDS)
--build-two-config
--build-project ExtFort
--build-generator ${CMAKE_GENERATOR}
+ --build-generator-platform "${CMAKE_GENERATOR_PLATFORM}"
--build-generator-toolset "${CMAKE_GENERATOR_TOOLSET}"
--build-options -DCMAKE_Fortran_COMPILER:STRING=${CMAKE_Fortran_COMPILER}
-DCMAKE_Fortran_FLAGS:STRING=${CMAKE_Fortran_FLAGS}