summaryrefslogtreecommitdiffstats
path: root/Tests/Fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-02-24 19:32:31 (GMT)
committerBrad King <brad.king@kitware.com>2009-02-24 19:32:31 (GMT)
commitff32962a682387ada24a7485a1bd21a3fc1b19d4 (patch)
tree40e54183224937af5d68cf6c26bf4feff6cefed1 /Tests/Fortran/CMakeLists.txt
parent66f2edbe635b6f0ae740a1a614cbddc831ce383e (diff)
downloadCMake-ff32962a682387ada24a7485a1bd21a3fc1b19d4.zip
CMake-ff32962a682387ada24a7485a1bd21a3fc1b19d4.tar.gz
CMake-ff32962a682387ada24a7485a1bd21a3fc1b19d4.tar.bz2
ENH: Test included header in Fortran preprocessing
This extends the Fortran preprocessing test to include a header file through a preprocessor directive.
Diffstat (limited to 'Tests/Fortran/CMakeLists.txt')
-rw-r--r--Tests/Fortran/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/Fortran/CMakeLists.txt b/Tests/Fortran/CMakeLists.txt
index e8515c4..e4fc4c2 100644
--- a/Tests/Fortran/CMakeLists.txt
+++ b/Tests/Fortran/CMakeLists.txt
@@ -127,6 +127,7 @@ if(CMAKE_Fortran_COMPILER_SUPPORTS_F90)
in_interface/module.f90)
add_definitions(-DFOO -DBAR=1)
+ include_directories(${testf_SOURCE_DIR}/include)
add_executable(test_preprocess test_preprocess.F90)
set(TEST_MODULE_DEPENDS 1)