summaryrefslogtreecommitdiffstats
path: root/Tests/Fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2007-10-10 13:09:09 (GMT)
committerBrad King <brad.king@kitware.com>2007-10-10 13:09:09 (GMT)
commitaa9ba5c3efcd32ea631435318f63dc476ac39798 (patch)
tree7cde06b78ec51ef50142455d70ca8c2da9c7c86f /Tests/Fortran/CMakeLists.txt
parentea56464864674a8dd13e417c69d68bd9a80ff5fa (diff)
downloadCMake-aa9ba5c3efcd32ea631435318f63dc476ac39798.zip
CMake-aa9ba5c3efcd32ea631435318f63dc476ac39798.tar.gz
CMake-aa9ba5c3efcd32ea631435318f63dc476ac39798.tar.bz2
ENH: Added test for 'use' keyword in a comment. Patch from Maik Beckmann. See bug#5809.
Diffstat (limited to 'Tests/Fortran/CMakeLists.txt')
-rw-r--r--Tests/Fortran/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/Fortran/CMakeLists.txt b/Tests/Fortran/CMakeLists.txt
index 99132de..c6c6689 100644
--- a/Tests/Fortran/CMakeLists.txt
+++ b/Tests/Fortran/CMakeLists.txt
@@ -12,4 +12,14 @@ IF(CMAKE_Fortran_COMPILER_SUPPORTS_F90)
test_module_main.f90
test_module_implementation.f90
test_module_interface.f90)
+
+ ADD_EXECUTABLE(test_use_in_comment_fixedform
+ test_use_in_comment_fixedform.f)
+ ADD_EXECUTABLE(test_use_in_comment_freeform
+ test_use_in_comment_freeform.f90)
+
+ ADD_EXECUTABLE(test_in_interface
+ in_interface/main.f90
+ in_interface/module.f90)
+
ENDIF(CMAKE_Fortran_COMPILER_SUPPORTS_F90)