summaryrefslogtreecommitdiffstats
path: root/Tests/Fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-01-09 15:30:11 (GMT)
committerBrad King <brad.king@kitware.com>2008-01-09 15:30:11 (GMT)
commitb761da39c14c9f003d9113418aca9370f30a5e6e (patch)
tree3307dab56eb95df89992cb8c407dbe6d9d625fe4 /Tests/Fortran/CMakeLists.txt
parent09e309c3d097f8cc58fc16c4194d0f51dec9f02d (diff)
downloadCMake-b761da39c14c9f003d9113418aca9370f30a5e6e.zip
CMake-b761da39c14c9f003d9113418aca9370f30a5e6e.tar.gz
CMake-b761da39c14c9f003d9113418aca9370f30a5e6e.tar.bz2
ENH: Patch from Maik to add preprocessor directive handling to Fortran dependency scanning. Also added -fpp flag to Intel Fortran compiler on Windows by default.
Diffstat (limited to 'Tests/Fortran/CMakeLists.txt')
-rw-r--r--Tests/Fortran/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/Fortran/CMakeLists.txt b/Tests/Fortran/CMakeLists.txt
index 3a299b2..54f18d0 100644
--- a/Tests/Fortran/CMakeLists.txt
+++ b/Tests/Fortran/CMakeLists.txt
@@ -23,6 +23,9 @@ IF(CMAKE_Fortran_COMPILER_SUPPORTS_F90)
in_interface/main.f90
in_interface/module.f90)
+ ADD_DEFINITIONS(-DFOO -DBAR=1)
+ ADD_EXECUTABLE(test_preprocess test_preprocess.F90)
+
SET(TEST_MODULE_DEPENDS 1)
ENDIF(CMAKE_Fortran_COMPILER_SUPPORTS_F90)