summaryrefslogtreecommitdiffstats
path: root/Tests/FortranC/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2022-10-11 19:35:43 (GMT)
committerBrad King <brad.king@kitware.com>2022-10-11 19:38:48 (GMT)
commit0301779e8532626c106f38e4f8e227c89ba1b158 (patch)
tree3b4cd5af8acb117c7db937f28dee6d1db829cf61 /Tests/FortranC/CMakeLists.txt
parent5d24e9e09b21b05c7bad67303adbbac0137b51c3 (diff)
downloadCMake-0301779e8532626c106f38e4f8e227c89ba1b158.zip
CMake-0301779e8532626c106f38e4f8e227c89ba1b158.tar.gz
CMake-0301779e8532626c106f38e4f8e227c89ba1b158.tar.bz2
LLVMFlang: Add support for mixed-language linking with Fortran
Parse implicit link information for this compiler to support mixed-language linking. This was missed by commit 85749766df (LLVMFlang: Add support for LLVM Flang, 2021-07-07, v3.24.0-rc1~86^2). Also activate mixed-language test cases that would have caught this. Issue: #22387
Diffstat (limited to 'Tests/FortranC/CMakeLists.txt')
-rw-r--r--Tests/FortranC/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/FortranC/CMakeLists.txt b/Tests/FortranC/CMakeLists.txt
index 83c2729..1403aa0 100644
--- a/Tests/FortranC/CMakeLists.txt
+++ b/Tests/FortranC/CMakeLists.txt
@@ -3,7 +3,7 @@ project(FortranC C Fortran)
# Skip this test for compilers not known to be compatible.
if(NOT (CMAKE_C_COMPILER_ID STREQUAL CMAKE_Fortran_COMPILER_ID OR
- "${CMAKE_C_COMPILER_ID}-${CMAKE_Fortran_COMPILER_ID}" MATCHES "^(MSVC-Intel)$"))
+ "${CMAKE_C_COMPILER_ID}-${CMAKE_Fortran_COMPILER_ID}" MATCHES "^(MSVC-Intel|(GNU|Clang)-LLVMFlang)$"))
message(STATUS "${CMAKE_C_COMPILER_ID} C and ${CMAKE_Fortran_COMPILER_ID} Fortran not known to be compatible!")
return()
endif()