summaryrefslogtreecommitdiffstats
path: root/Tests/FortranModules/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2023-09-18 23:59:56 (GMT)
committerBrad King <brad.king@kitware.com>2023-09-20 13:14:58 (GMT)
commit978b68d3bbb44e3bc6adbe5109eb8295f8232ce6 (patch)
treece2024d7bca4816b4ef41672c3067e48bd0660ac /Tests/FortranModules/CMakeLists.txt
parent619aca80ae94b909085344af1098c7f4bf80f0c2 (diff)
downloadCMake-978b68d3bbb44e3bc6adbe5109eb8295f8232ce6.zip
CMake-978b68d3bbb44e3bc6adbe5109eb8295f8232ce6.tar.gz
CMake-978b68d3bbb44e3bc6adbe5109eb8295f8232ce6.tar.bz2
add_custom_target: Fix regression with Fortran sources
Since commit 74b1d6caf3 (cmComputeLinkInformation: compute link info for module-using targets, 2023-09-05, v3.27.5~7^2) we accidentally try to compute link information for custom targets if they have Fortran sources. For module dependencies, we only need to consider target types that can compile. Fixes: #25252
Diffstat (limited to 'Tests/FortranModules/CMakeLists.txt')
-rw-r--r--Tests/FortranModules/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/FortranModules/CMakeLists.txt b/Tests/FortranModules/CMakeLists.txt
index f5b2822..8ebd9b2 100644
--- a/Tests/FortranModules/CMakeLists.txt
+++ b/Tests/FortranModules/CMakeLists.txt
@@ -128,3 +128,7 @@ endif()
add_subdirectory(Issue25112)
add_subdirectory(Issue25223)
+if( # Intel Fortran VS Integration breaks on custom targets with Fortran sources
+ NOT CMAKE_GENERATOR MATCHES "Visual Studio")
+ add_subdirectory(Issue25252)
+endif()