summaryrefslogtreecommitdiffstats
path: root/Tests/FortranModules/Submodules/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-04-19 15:26:06 (GMT)
committerBrad King <brad.king@kitware.com>2018-04-20 14:57:32 (GMT)
commitb1f95e5b1477794c0ee3a56a4ea016a34c3e3d5c (patch)
tree715af1b794f404479f96a5932d2d1ea9b0187490 /Tests/FortranModules/Submodules/CMakeLists.txt
parent402735314ec7fe48ec21e5f4c5b19b6f17682c54 (diff)
downloadCMake-b1f95e5b1477794c0ee3a56a4ea016a34c3e3d5c.zip
CMake-b1f95e5b1477794c0ee3a56a4ea016a34c3e3d5c.tar.gz
CMake-b1f95e5b1477794c0ee3a56a4ea016a34c3e3d5c.tar.bz2
Fortran: Extend submodule test with great-grandchild
Name the module using CamelCase to test lower-case file name conversion. Also add coverage of existing "sibling" module.
Diffstat (limited to 'Tests/FortranModules/Submodules/CMakeLists.txt')
-rw-r--r--Tests/FortranModules/Submodules/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/FortranModules/Submodules/CMakeLists.txt b/Tests/FortranModules/Submodules/CMakeLists.txt
index da204d0..ab8e0f9 100644
--- a/Tests/FortranModules/Submodules/CMakeLists.txt
+++ b/Tests/FortranModules/Submodules/CMakeLists.txt
@@ -8,6 +8,8 @@
# child sibling
# |
# grandchild
+# |
+# GreatGrandChild
#
# where the parent node is a module and all other nodes are submodules.
@@ -16,5 +18,6 @@ add_executable(submod
parent.f90
child.f90
grandchild.f90
+ greatgrandchild.f90
sibling.f90
)