summaryrefslogtreecommitdiffstats
path: root/Tests/FortranOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorTin Huynh <ahuynh@nvidia.com>2021-01-27 08:00:58 (GMT)
committerBrad King <brad.king@kitware.com>2021-01-27 14:53:02 (GMT)
commit4de28ba4e6348f99de57bd2961b00dcd4cda213b (patch)
treed847cafc0c0816e3827fbe73d555316410a48232 /Tests/FortranOnly/CMakeLists.txt
parent90502d76b7259fb8b417b1a81b504061ce592465 (diff)
downloadCMake-4de28ba4e6348f99de57bd2961b00dcd4cda213b.zip
CMake-4de28ba4e6348f99de57bd2961b00dcd4cda213b.tar.gz
CMake-4de28ba4e6348f99de57bd2961b00dcd4cda213b.tar.bz2
Tests: Update tests for NVHPC compiler
Treat it just like PGI.
Diffstat (limited to 'Tests/FortranOnly/CMakeLists.txt')
-rw-r--r--Tests/FortranOnly/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/FortranOnly/CMakeLists.txt b/Tests/FortranOnly/CMakeLists.txt
index 637f581..b40f05e 100644
--- a/Tests/FortranOnly/CMakeLists.txt
+++ b/Tests/FortranOnly/CMakeLists.txt
@@ -146,7 +146,7 @@ set_property(SOURCE no_preprocess_source_lower.f PROPERTY Fortran_PREPROCESS OFF
# Test that we can explicitly not preprocess a target or source.
# This will not work on certain compilers due to either missing a
# "don't preprocess" flag, or due to choice of file extension.
-if(test_pp_flags AND NOT CMAKE_Fortran_COMPILER_ID MATCHES "(Flang|NAG|PGI|SunPro|XL)")
+if(test_pp_flags AND NOT CMAKE_Fortran_COMPILER_ID MATCHES "(Flang|NAG|PGI|NVHPC|SunPro|XL)")
add_library(no_preprocess_target STATIC no_preprocess_target_upper.F)
target_compile_options(no_preprocess_target PRIVATE -DINTEGER=nonsense)
add_library(no_preprocess_source STATIC no_preprocess_source_upper.F)