summaryrefslogtreecommitdiffstats
path: root/Tests/Framework/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-04-08 04:06:47 (GMT)
committerBrad King <brad.king@kitware.com>2008-04-08 04:06:47 (GMT)
commit67834f2d535b46655074932371d9e4f2f024c44c (patch)
tree2a688fad6dd6a2043af7109433b5a1c2a91bd7f0 /Tests/Framework/CMakeLists.txt
parent5c3a5daaf1f0ccaa447ad3856f2ee8445d3df325 (diff)
downloadCMake-67834f2d535b46655074932371d9e4f2f024c44c.zip
CMake-67834f2d535b46655074932371d9e4f2f024c44c.tar.gz
CMake-67834f2d535b46655074932371d9e4f2f024c44c.tar.bz2
BUG: Correct Mac OS X framework behavior
- Place the built library in foo.framework/Versions/A/foo - Do not create unused content symlinks (like PrivateHeaders) - Do not use VERSION/SOVERSION properties for frameworks - Make cmTarget::GetDirectory return by value - Remove the foo.framework part from cmTarget::GetDirectory - Correct install_name construction and conversion on install - Fix MACOSX_PACKAGE_LOCATION under Xcode to use the Versions/<version> directory for frameworks - Update the Framework test to try these things
Diffstat (limited to 'Tests/Framework/CMakeLists.txt')
-rw-r--r--Tests/Framework/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/Framework/CMakeLists.txt b/Tests/Framework/CMakeLists.txt
index 58c2cfb..3eb0dbc 100644
--- a/Tests/Framework/CMakeLists.txt
+++ b/Tests/Framework/CMakeLists.txt
@@ -10,8 +10,11 @@ add_library(foo SHARED
fooNeither.h
fooBoth.h
test.lua
+ fooDeepPublic.h
)
-
+set_property(SOURCE fooDeepPublic.h
+ PROPERTY MACOSX_PACKAGE_LOCATION Headers/Deep
+ )
set(foo_ver ver4)
set_target_properties(foo PROPERTIES
@@ -20,6 +23,7 @@ set_target_properties(foo PROPERTIES
PRIVATE_HEADER "fooPrivate.h;fooBoth.h"
PUBLIC_HEADER "foo.h;foo2.h;fooPublic.h;fooBoth.h"
RESOURCE "test.lua"
+ INSTALL_NAME_DIR "@executable_path/../../../Library/Frameworks"
)
# fooBoth.h is listed as both public and private... (private wins...)
# fooNeither.h is listed as neither public nor private...