summaryrefslogtreecommitdiffstats
path: root/Tests/Framework/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2007-05-08 14:58:35 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2007-05-08 14:58:35 (GMT)
commitb39d96dff85d9fe8b236f9519f5d7d9b8c9f2880 (patch)
tree3703589a3ae6dbe20e586d761e62ddec2492b2e6 /Tests/Framework/CMakeLists.txt
parent9323a2798973b3dbe8ca9725f1cb5c8ff6d5900b (diff)
downloadCMake-b39d96dff85d9fe8b236f9519f5d7d9b8c9f2880.zip
CMake-b39d96dff85d9fe8b236f9519f5d7d9b8c9f2880.tar.gz
CMake-b39d96dff85d9fe8b236f9519f5d7d9b8c9f2880.tar.bz2
ENH: add a very simple framework test
Diffstat (limited to 'Tests/Framework/CMakeLists.txt')
-rw-r--r--Tests/Framework/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/Framework/CMakeLists.txt b/Tests/Framework/CMakeLists.txt
new file mode 100644
index 0000000..3aac24d
--- /dev/null
+++ b/Tests/Framework/CMakeLists.txt
@@ -0,0 +1,11 @@
+project(Framework)
+add_library(foo SHARED foo.cxx)
+set_target_properties(foo PROPERTIES
+ FRAMEWORK TRUE
+ FRAMEWORK_PUBLIC_HEADERS "foo.h;foo2.h"
+ FRAMEWORK_VERSION ver2
+ FRAMEWORK_RESOURCES ""
+# VERSION 1.2
+)
+add_executable(bar bar.cxx)
+target_link_libraries(bar foo)