summaryrefslogtreecommitdiffstats
path: root/Tests/Framework/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2021-03-10 14:37:00 (GMT)
committerBrad King <brad.king@kitware.com>2021-03-10 15:01:11 (GMT)
commit4f9a71974e0d6e34c81fd8f55fce4118157e5559 (patch)
treeb6e7d627e23575e8b7f9d28bce6d260103ce0e44 /Tests/Framework/CMakeLists.txt
parent214a06ec2ec567cd31aabdb3ada6421f965c5dfa (diff)
downloadCMake-4f9a71974e0d6e34c81fd8f55fce4118157e5559.zip
CMake-4f9a71974e0d6e34c81fd8f55fce4118157e5559.tar.gz
CMake-4f9a71974e0d6e34c81fd8f55fce4118157e5559.tar.bz2
Xcode: Restore support for spaces in framework names
In commit ce2dee9e5b (Xcode: Don't add framework as -framework argument in linker info list, 2020-09-28, v3.19.0-rc1~47^2) we split up the path to a framework into the directory and framework name parts, but only retained the quoting on the directory part. Restore quoting of the framework name. Fixes: #21910
Diffstat (limited to 'Tests/Framework/CMakeLists.txt')
-rw-r--r--Tests/Framework/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/Tests/Framework/CMakeLists.txt b/Tests/Framework/CMakeLists.txt
index f741ec2..aabf6b4 100644
--- a/Tests/Framework/CMakeLists.txt
+++ b/Tests/Framework/CMakeLists.txt
@@ -83,6 +83,16 @@ if(NOT XCODE OR NOT XCODE_VERSION VERSION_LESS 5)
target_link_libraries(barStatic fooStatic)
endif()
+if(XCODE)
+ add_library(space SHARED space.c)
+ set_target_properties(space PROPERTIES
+ FRAMEWORK TRUE
+ OUTPUT_NAME "space space"
+ )
+ add_executable(use_space use_space.c)
+ target_link_libraries(use_space PRIVATE space)
+endif()
+
include(CPack)
if(APPLE)