summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-10-04 08:27:34 (GMT)
committerBrad King <brad.king@kitware.com>2012-10-09 12:26:54 (GMT)
commit78e54b99fed1bd4c899360c9df779205ce6b29ba (patch)
treec1dac7547820f79a5085770356f3d1c4f608b0fa /Tests/GeneratorExpression/CMakeLists.txt
parentd729e8b74ccdf14d809a1b7f9260a5a1d225c2bc (diff)
downloadCMake-78e54b99fed1bd4c899360c9df779205ce6b29ba.zip
CMake-78e54b99fed1bd4c899360c9df779205ce6b29ba.tar.gz
CMake-78e54b99fed1bd4c899360c9df779205ce6b29ba.tar.bz2
GenEx: Add tests for "0" and "1" expressions with literal commas.
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index 41639ac..8bc4f32 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -4,7 +4,9 @@ project(GeneratorExpression NONE)
add_custom_target(check ALL
COMMAND ${CMAKE_COMMAND}
-Dtest_0=$<0:nothing>
+ -Dtest_0_with_comma=$<0:-Wl,--no-undefined>
-Dtest_1=$<1:content>
+ -Dtest_1_with_comma=$<1:-Wl,--no-undefined>
-Dconfig=$<CONFIGURATION>
-Dtest_and_0=$<AND:0>
-Dtest_and_0_0=$<AND:0,0>