summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-10-04 08:24:32 (GMT)
committerBrad King <brad.king@kitware.com>2012-10-09 12:26:51 (GMT)
commitd729e8b74ccdf14d809a1b7f9260a5a1d225c2bc (patch)
tree2193b28bfea5bb90a535882347448121870ea56a /Tests/GeneratorExpression/CMakeLists.txt
parent354face4fa234adfe6f056dc9d3039fc135ab4ef (diff)
downloadCMake-d729e8b74ccdf14d809a1b7f9260a5a1d225c2bc.zip
CMake-d729e8b74ccdf14d809a1b7f9260a5a1d225c2bc.tar.gz
CMake-d729e8b74ccdf14d809a1b7f9260a5a1d225c2bc.tar.bz2
GenEx: Add test for $<BOOL:> with empty parameter.
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index 6494107..41639ac 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -30,6 +30,7 @@ add_custom_target(check ALL
-Dtest_bool_off=$<BOOL:Off>
-Dtest_bool_no=$<BOOL:No>
-Dtest_bool_n=$<BOOL:N>
+ -Dtest_bool_empty=$<BOOL:>
-Dtest_strequal_yes_yes=$<STREQUAL:Yes,Yes>
-Dtest_strequal_yes_yes_cs=$<STREQUAL:Yes,yes>
-Dtest_strequal_yes_no=$<STREQUAL:Yes,No>