summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-12-26 14:59:55 (GMT)
committerStephen Kelly <steveire@gmail.com>2014-01-08 15:41:34 (GMT)
commit6aabb6a62b679f64e278087fc671cd33a35bf871 (patch)
treeabf9f40e80fd8577e3cdda4fcd8a8cfd0b6b2037 /Tests/GeneratorExpression/CMakeLists.txt
parent5bb53f6b731228e4592066329e8992987289a986 (diff)
downloadCMake-6aabb6a62b679f64e278087fc671cd33a35bf871.zip
CMake-6aabb6a62b679f64e278087fc671cd33a35bf871.tar.gz
CMake-6aabb6a62b679f64e278087fc671cd33a35bf871.tar.bz2
Genex: Use case-sensitive comparison for COMPILER_ID.
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index 3b85dc3..a0e34ef 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -252,3 +252,9 @@ endforeach()
add_test(echo-old-style echo "\$<CONFIGURATION>")
set_property(TEST echo-old-style PROPERTY
PASS_REGULAR_EXPRESSION "^\\$<CONFIGURATION>\n$")
+
+add_subdirectory(CMP0044 ${CMAKE_BINARY_DIR}/CMP0044-WARN)
+set(CMP0044_TYPE NEW)
+add_subdirectory(CMP0044 ${CMAKE_BINARY_DIR}/CMP0044-NEW)
+set(CMP0044_TYPE OLD)
+add_subdirectory(CMP0044 ${CMAKE_BINARY_DIR}/CMP0044-OLD)