summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-08-27 08:57:16 (GMT)
committerStephen Kelly <steveire@gmail.com>2013-08-28 08:23:20 (GMT)
commitdcc00ece4b297f94974b84783805af9c01b6e681 (patch)
tree54939d4cdad6cdcec127d92a2f05c3fa03cffbf4 /Tests/GeneratorExpression/CMakeLists.txt
parent150bc7da3dba160acab5cb11387c9a29255973ac (diff)
downloadCMake-dcc00ece4b297f94974b84783805af9c01b6e681.zip
CMake-dcc00ece4b297f94974b84783805af9c01b6e681.tar.gz
CMake-dcc00ece4b297f94974b84783805af9c01b6e681.tar.bz2
Genex: Add the PLATFORM_ID expression.
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index 4d8d7ed..47e7882 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -186,6 +186,11 @@ add_custom_target(check-part3 ALL
-Dtest_alias_target_name=$<STREQUAL:$<TARGET_PROPERTY:Alias::SomeLib,NAME>,$<TARGET_PROPERTY:empty1,NAME>>
-Dtest_early_termination_1=$<$<1:>:
-Dtest_early_termination_2=$<$<1:>:,
+ -Dsystem_name=${CMAKE_HOST_SYSTEM_NAME}
+ -Dtest_platform_id=$<PLATFORM_ID>
+ -Dtest_platform_id_Linux=$<PLATFORM_ID:Linux>
+ -Dtest_platform_id_Windows=$<PLATFORM_ID:Windows>
+ -Dtest_platform_id_Darwin=$<PLATFORM_ID:Darwin>
-P ${CMAKE_CURRENT_SOURCE_DIR}/check-part3.cmake
COMMAND ${CMAKE_COMMAND} -E echo "check done (part 3 of 3)"
VERBATIM