summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-01-26 15:09:55 (GMT)
committerBrad King <brad.king@kitware.com>2017-01-26 15:09:55 (GMT)
commit1a2a9b0d08c7ba2af168856b1220d42ff9a80921 (patch)
tree21d8e8913b298d5012a9c23acc9b55afcf5a0c53 /Tests/GeneratorExpression/CMakeLists.txt
parenta45de72cc437a13179e933509d524d2088a86002 (diff)
downloadCMake-1a2a9b0d08c7ba2af168856b1220d42ff9a80921.zip
CMake-1a2a9b0d08c7ba2af168856b1220d42ff9a80921.tar.gz
CMake-1a2a9b0d08c7ba2af168856b1220d42ff9a80921.tar.bz2
Tests: Simplify GeneratorExpression imported include directory check
Do not duplicate the list of include directories 4 times.
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index f0d6abf..8ecfdd9 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -187,10 +187,7 @@ add_custom_target(check-part3 ALL
-Dtest_version_equal_1=$<VERSION_EQUAL:1.0.1,1.1>
-Dtest_version_equal_2=$<VERSION_EQUAL:1.1,1.1>
-Dconfig=$<CONFIGURATION>
- -Dtest_imported_debug=$<TARGET_PROPERTY:imported4,INCLUDE_DIRECTORIES>
- -Dtest_imported_release=$<TARGET_PROPERTY:imported4,INCLUDE_DIRECTORIES>
- -Dtest_imported_relwithdebinfo=$<TARGET_PROPERTY:imported4,INCLUDE_DIRECTORIES>
- -Dtest_imported_minsizerel=$<TARGET_PROPERTY:imported4,INCLUDE_DIRECTORIES>
+ -Dtest_imported_includes=$<TARGET_PROPERTY:imported4,INCLUDE_DIRECTORIES>
-Dtest_imported_fallback=$<STREQUAL:$<TARGET_FILE_NAME:importedFallback>,fallback_loc>
-Dtest_alias_file_exe=$<STREQUAL:$<TARGET_FILE:Alias::SomeExe>,$<TARGET_FILE:someexe>>
-Dtest_alias_file_lib=$<STREQUAL:$<TARGET_FILE:Alias::SomeLib>,$<TARGET_FILE:empty1>>