summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorJean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>2013-03-12 06:52:01 (GMT)
committerBrad King <brad.king@kitware.com>2013-03-12 20:46:03 (GMT)
commit7f3bb8b39234766b48e0dd18a47ed46d6fa176e6 (patch)
treee5530f01045cd27a1f357841f3008a7e5cff010f /Tests/GeneratorExpression/CMakeLists.txt
parent153242601e22d6f06e1f14dc55d70c2a42b2ec5f (diff)
downloadCMake-7f3bb8b39234766b48e0dd18a47ed46d6fa176e6.zip
CMake-7f3bb8b39234766b48e0dd18a47ed46d6fa176e6.tar.gz
CMake-7f3bb8b39234766b48e0dd18a47ed46d6fa176e6.tar.bz2
Add $<SEMICOLON> generator expression.
This expression is useful to put a ';' in a command line argument without dividing the argument during CMake list expansion.
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index fff7c87..0008c16 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -47,11 +47,13 @@ add_custom_target(check-part1 ALL
-Dtest_strequal_no_yes=$<STREQUAL:No,Yes>
-Dtest_strequal_angle_r=$<STREQUAL:$<ANGLE-R>,$<ANGLE-R>>
-Dtest_strequal_comma=$<STREQUAL:$<COMMA>,$<COMMA>>
+ -Dtest_strequal_semicolon=$<STREQUAL:$<SEMICOLON>,$<SEMICOLON>>
-Dtest_strequal_angle_r_comma=$<STREQUAL:$<ANGLE-R>,$<COMMA>>
-Dtest_strequal_both_empty=$<STREQUAL:,>
-Dtest_strequal_one_empty=$<STREQUAL:something,>
-Dtest_angle_r=$<ANGLE-R>
-Dtest_comma=$<COMMA>
+ -Dtest_semicolon=$<SEMICOLON>
-Dtest_colons_1=$<1::>
-Dtest_colons_2=$<1:::>
-Dtest_colons_3=$<1:Qt5::Core>