summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2012-11-01 13:21:25 (GMT)
committerBrad King <brad.king@kitware.com>2012-11-05 13:49:25 (GMT)
commit9be64f34c299edfa69b126d419b4bd0619741656 (patch)
tree2c32852ad6bb1d6c19f0f8cbd8a90d831f1d35e3 /Tests/GeneratorExpression/CMakeLists.txt
parenta7742140ad1a88e354037ea391c0e773f147ebd2 (diff)
downloadCMake-9be64f34c299edfa69b126d419b4bd0619741656.zip
CMake-9be64f34c299edfa69b126d419b4bd0619741656.tar.gz
CMake-9be64f34c299edfa69b126d419b4bd0619741656.tar.bz2
GenEx: Use case insensitive comparison for $<CONFIG:...>
This fixes a regression introduced by commit f1eacf0e (cmGeneratorExpression: Re-write for multi-stage evaluation).
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index 891fa11..bb31476 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -16,6 +16,10 @@ add_custom_target(check ALL
-Dtest_and_1_1=$<AND:1,1>
-Dtest_config_0=$<CONFIG:$<CONFIGURATION>x>
-Dtest_config_1=$<CONFIG:$<CONFIGURATION>>
+ -Dtest_config_debug=$<CONFIG:Debug>$<CONFIG:DEBUG>$<CONFIG:DeBuG>
+ -Dtest_config_release=$<CONFIG:Release>$<CONFIG:RELEASE>$<CONFIG:ReLeAsE>
+ -Dtest_config_relwithdebinfo=$<CONFIG:RelWithDebInfo>$<CONFIG:RELWITHDEBINFO>$<CONFIG:relwithdebinfo>
+ -Dtest_config_minsizerel=$<CONFIG:MinSizeRel>$<CONFIG:MINSIZEREL>$<CONFIG:minsizerel>
-Dtest_not_0=$<NOT:0>
-Dtest_not_1=$<NOT:1>
-Dtest_or_0=$<OR:0>