summaryrefslogtreecommitdiffstats
path: root/Tests/GeneratorExpression/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-12-31 14:57:25 (GMT)
committerBrad King <brad.king@kitware.com>2014-01-07 14:38:01 (GMT)
commit3917d86b261f0b88eb5cf0e8d2700c70cebdbe4b (patch)
treeb870364a3fec0acba6eb8c320f665ed181281535 /Tests/GeneratorExpression/CMakeLists.txt
parent5169130539110ff479875e76784109f174c28c69 (diff)
downloadCMake-3917d86b261f0b88eb5cf0e8d2700c70cebdbe4b.zip
CMake-3917d86b261f0b88eb5cf0e8d2700c70cebdbe4b.tar.gz
CMake-3917d86b261f0b88eb5cf0e8d2700c70cebdbe4b.tar.bz2
Genex: Add a nullary form for CONFIG
This is consistent with other similar expressions such as PLATFORM_ID, and makes the CONFIGURATION expression obsolete. Fix an off-by-one error in GeneratorExpressionContent::EvaluateParameters exposed by a unit test. Remove the test for 'bad' nullary use of $<CONFIG>. Add a unit test to verify that $<CONFIG> and $<CONFIGURATION> have the same value.
Diffstat (limited to 'Tests/GeneratorExpression/CMakeLists.txt')
-rw-r--r--Tests/GeneratorExpression/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/GeneratorExpression/CMakeLists.txt b/Tests/GeneratorExpression/CMakeLists.txt
index 9512efc..3b85dc3 100644
--- a/Tests/GeneratorExpression/CMakeLists.txt
+++ b/Tests/GeneratorExpression/CMakeLists.txt
@@ -13,6 +13,7 @@ add_custom_target(check-part1 ALL
-Dtest_1=$<1:content>
-Dtest_1_with_comma=$<1:-Wl,--no-undefined>
-Dconfig=$<CONFIGURATION>
+ -Dshort_config=$<CONFIG>
-Dtest_and_0=$<AND:0>
-Dtest_and_0_0=$<AND:0,0>
-Dtest_and_0_1=$<AND:0,1>